No pulses recorded by emonTx (TSL257) - solved

I have hooked the emonTX up to the pulse LED on my power meter (using the "TSL257 optical pulse sensing kit"). The emonTx is sending packages to the emonBase but it seems that the emonTx is not recording any pulses.  


1 emontx packet rx2 {rf_fail:0,power:0,pulse:0}
3 ok | Date: Thu, 05 Apr 2012 18:55:19 GMT
4 emonbase sent
I keep on getting power:0 and pulse:0
Using the sketches from git (emonTx_puls and NanodeRF_Power_RTCrelay_GLCDtemp) with only minor changes (as described here:

Q: How do I find out what is causing this issue? (must be either my emonTX or the TSL257 sensor) 

Drsdre's picture

Re: No pulses recorded by emonTx (TSL257) - solved

I would first recommend to check your emonTX board if you made the 5 volt soldering pad connection (see also I overlooked this one and at start also didn't get any readings.

If this still doesn't give you a working setup check the sensor by using a DC volt meter and reading on the pins Gnd and Out (see When sensor is covered voltage is low, if sensor is in light voltage should be almost to Vcc level (5 volt). Also recheck if you made the right connections from sensor to plug (and check if plug was inserted all the way into the socket of emonTX.




trendt's picture

Re: No pulses recorded by emonTx (TSL257) - solved

That could be it! I haven't made a connection to either 3.3v or 5v. Actually made a similar mistake on the emonBase :-)

How do I know whether to choose 3.3 or 5v for the pulse jack? I'm planing to power the emonTx using USB. The link ( claims that 3.3 is sufficient when detecting LED pulses (what I'm planing to do). Did you end up choosing 5v? why? :-) 

logic's picture

Re: No pulses recorded by emonTx (TSL257) - solved

Edit - deleted due to link being same as above - sorry.



glyn.hudson's picture

Re: No pulses recorded by emonTx (TSL257) - solved

TSL257 optical sensor has a supply voltage range 2.7V-5.5V so it doesn't matter. I would recommend using 3.3V, as that's what I've used in the past and it works well. the 5V setting is more useful if interfacing directly (not optical) with a pulse output meter or using the emonTx pulse I/O to control a 5V realay. We really need to write some better documentation about this, at the moment all there is to go on is that blogpost which is not particularly well linked. 

Link to TSL357 datasheet on this page:

trendt's picture

Re: No pulses recorded by emonTx (TSL257) - solved

Thanks :-) Forgot to reply to this tread. Ended up choosing 3.3 v after re-reading the above blog post. Seems to work perfectly. 

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.