Solved - Unable to communicate [UNO+EmonTX Shield with Raspi+RFM12Pi]

Hi guys.

I'm having serious problems with setup, I can't receive anything in my remote account from emoncms (also, my RFM12Pi don't flash).

I've created some nodes using the API, but I can't get them to update, so I'm not receiving any data at all.

My setup:

On the emonBase side I'm running: a Raspberry Pi [Model B.512] with a RFM12Pi [433Mhz] using the oem_gateway22oct2013 image.

On the emonTx side i'm running: an Arduino UNO [using Shield_CT1234.ino file from emonTxShield examples] with an emonTx Shield (v1.0) connected to two CT sensors.


Configs & Status:

Base side:

- I've installed the oemgateway image following this guide:

- The RFM12Pi lights only blinks when I power up the raspi.

- I've change the current settings in the oemgateway.conf file: [SGROUP = 210, FREQUENCY = 4, BASEID= 15 ] 

- I've switch RPI on, kill the process for debug purposes and started by hand - you can see the output in the screenshots.

EmonTX side:

- Current settings are[FREQ RF12_433MHZ, NODEID = 10, NETWORKGROUP = 210]

- The emonTx Shield LED blinks, and you can see the result in the screenshot from serial monitor.


Can anyone help me solving this problem? I've attached a lot of screenshots.

Thank you.

p3dro's picture

Re: Solved - Unable to communicate [UNO+EmonTX Shield with Raspi+RFM12Pi]


Solution: RFM12B Slave Select (SS) Solder Jumper Setting was soldered incorrectly.

Thank you all anyway!

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.