Troubleshooting RFM12Pi


I've got a working system and a spare RFM12Pi board which I've never tried to use.

When I power on the Pi, the green LED on the spare RFM12Pi lights up solid and minicom doesn't observe any traffic - works fine when I substitute the original RFM12Pi though.

I've successfully followed the wiki instructions for re-uploading to the RFM12Pi after a bit of a false start. However, the fact that the LED is lit solid doesn't seem promising to me.

Does anyone have any suggestions for troubleshooting this? I'd like to give the spare Pi and RFM12Pi away as a Chrismas gift, but I won't be thanked if it doesn't work ;-)

I don't have whatever is needed to re-flash the bootloader as far as I can tell (and the fact that the upload seems to work implies the bootloader is OK?)



pb66's picture

Re: Troubleshooting RFM12Pi

Hi Dave

Do you know if it is software or hardware holding the led on? if there are no clues (flashing, delay or any sign of control etc) you may need to change the "ledpin" in the RF12demo and reload to establish this.

Which model is it? is it a standard v2 with an rfm12 ? and which firmware are loading ?

Why did you decide to change firmware was it doing exactly the same before or is it just since upload ?


Schism's picture

Re: Troubleshooting RFM12Pi

Hey Paul,

I just tried uploading as a possible fix as I'd never used the board before. It has Feb 2013 stamped on it the same as my other RFM12Pi board from memory - I don't have them handy to compare right now. The green light comes on with the USB power to the Pi and stays on.

I hadn't really considered changing the sketch but I suppose another option would be to upload one causing it to transmit when powered up (I'd then receive that on my "production" Pi)?

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.