problem getting DS18B20 working


I'm feeling like such an idiot, something so simple I can't seem to see why its not working.

I've got my openEnergyMonitoring components on order, and just can't help but tinker again with what I have. Was playing more with arduino a few years ago, so thought I'd just get the bunch of DS18B20's working again.

Well, it used to work and I've tried pretty much ever combination I can think of, was following this, checking double checking the wiring etc but still nothing, no devices detected. 

I use ArchLinux, so tried in a vm also LBunty, setting it all up the same, nothing.

I've got a Mega and a Deumlovem and bave tried with both of those. Blinking led on io port works.

I just don't know what to check next ? I've attached a picture... I'm basicly using any/all of the examples, just changing onewire pin to 12.

I've tried different temp sensors, nothing different, and have just moved to a different place on proto-board in case some bad connection, nothing.

Am I missing something simple ?



Robert Wall's picture

Re: problem getting DS18B20 working

Have you read the Building Blocks piece on temperature sensing?

(You need to tick "List" when you upload an attachment.)

WindyBoy's picture

Re: problem getting DS18B20 working

Many thanks Robert, 20 seconds after I read your reply I have it working... I'd, perhaps as you noticed from the picture got the sensor round the wrong way, and am a happy idiot. I hate to admit it but I had read that building blocks on the temp sensor, but had missed this, didn't think it was even possible.

I'd been looking at the datasheet, and had completely miss read that plan/front view in my hurry to get it working again after all this time.

Many thanks for the push in right direction.



Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.