Problem with rfm12b on emonGLCD.

Hi all iv recently bought and configured a new openenergymonitor for my parents.. (were all a bit weird)

anyway all was fine and dandy until today. the GLCD as stopped sending or receiving any data, It also seems to freeze after or around 60 seconds of use eg the buttons stop working..  

Iv tried jeelib rfm12demo..  Nothing just spits out 0? all the time.. even after setting the correct band group etc.. 

iv tried the jeelib pingpong nothing.. Know this works with other sensors and even my GLCD so know it should work.

Has the rfm12b died???  If so any easy way to remove it and replace it? or would you back to the guys at OEM to have a look.



Pics to follow.

robw's picture

Re: Problem with rfm12b on emonGLCD.

Sorry seems the photo upload is broken on here..  (too many mincepies i expect) They uploaded but then seem to vanish.

Has them on..

Robert Wall's picture

Re: Problem with rfm12b on emonGLCD.

I take it you're debugging the GLCD using serial output to check the data from the RFM12?

How long did it work?
Is there an interfering transmitter close by?
Will the GLCD both not transmit and not receive?

I don't know of an easy way to remove the RFM12B. You need to melt every joint simultaneously to remove it, and that could be quite difficult without the right tools.


robw's picture

Re: Problem with rfm12b on emonGLCD.

Hi Robert

Yes im using the serial port..  using the demos in the jeelib library..

It was working for around 3-5 days (It was not constantly on but was being used to test the stablity of the code..  I was building it and testing it for my parents hence this vagueness)..  It was running along side my own emonGLCD. 

Maybe there is a transmitter but it does not show up on my jeelink or effect the other emonGLCD no matter how close or far it is away when the other works fine..

The effected GLCD does not transmit or receive.. Well not that i can see. have tried with the rfm12bdemo

OK i thought that was going to be the answer.. The only good news is that the screen is not attached to the PCB well only with a plug strip so can be removed very easily. I maybe able to get some guys work in the electrical department to get a hot air gun on it but im not sure, will ask..  May fire off an email to Glyn or Trystan and see what they say if no one else has any ideas..

Thanks again though.


Robert Wall's picture

Re: Problem with rfm12b on emonGLCD.

The only suggestion I've seen for desoldering is to get a very large soldering iron and manufacture a custom bit that will span across the module and touch all 14 joints together. See here for an idea, but no promises that it'll work:  Also read this thread.

I've just had a thought: If you can get hold of some very thin stainless steel shim, it might be possible to slide it into each melted joint at a time. Solder won't stick to stainless steel. I haven't and don't intend to try this!

I think Glyn & Trystan's help is in order.

glyn.hudson's picture

Re: Problem with rfm12b on emonGLCD.

Hi Rob, 

Good work getting up and running. It's very strange for it to work for a bit them stop. Try our RFM12B simple tester: although If the JeeLabs RFM12 Demo doesnt work this probably won't either. 

How long did it work for before it stopped? Does the LCD still work? I'm guessing you can still upload code. 

It's possible that the RFM12 has packed up but this would be the first time we've heard of something like this happening..

We're happy to send you a replacement RFM12B, but as Robert has mentioned their not easy to de-solder. 

glyn.hudson's picture

Re: Problem with rfm12b on emonGLCD.

Could you measure the voltages on the 3.3V and 5V (PWR) rail? How have you been powering the unit? 

robw's picture

Re: Problem with rfm12b on emonGLCD.

Hi Glyn

3.3V reads 3.31V
PWR = 4.87V From USB programmer Its been powered from the programmer or one of your usb power supplies.

Yea I know I would expect it to work or not work from day one.. Strange. 

The Simple tester reports

RF12B demo Receiver - Simple demo
Node: 30 Freq: 868Mhz Network: 210

and nothing more.. Just seems to freeze 

Its been working on and off for 1-3 days at my house (testing / calibrating the emontx) and then a full 2 days at my parents it seemed to crash eg was not updating and so they pulled the power and re powered it then it just read 0 for every thing.. (told them they may need to do this as the GLCD does seem to lock up for me anyway currently)

The LCD works fine as does the uploading. All works as you would expect just nothing from the rfm12b.

Humm im not sure i would be so good at removing it. I'm OK ish at soldering but would not take the challenge of desoldering the rfm12b. I maybe able to ask the guys at work in our electrical department.. (I work in IT for a University) and they owe me a favor or two.

Will as but im not in untill Wednesday now so will have to wait..

If any other ideas please let me know.. Thanks Rob.


robw's picture

Re: Problem with rfm12b on emonGLCD.

Ummm,  i'm not really sure how but its fixed..

I set the frequency / node-id / group to all different numbers than i wanted to use.. Uploaded the sketch and then set them all back again and re upload. 

It seems to work correctly..

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.