In frustrated.

I bought the RFM12pi and tried to follow the wiki page how to upgrade the firmware. The wiki is quite unclear with the "Update" information added.

I have tried multiples times (cleaning up the RPi with a re-install) to get the upgrade to work. No sucess, each time gives me a the output below:

root@raspberrypi:/var/tmp/RFM2Pi/firmware/RF12_Demo_atmega328# avrdude -v -c arduino -p ATMEGA328P -P /dev/ttyAMA0 -b 38400

avrdude-original: Version 5.11.1, compiled on May 23 2012 at 11:08:25
                  Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
                  Copyright (c) 2007-2009 Joerg Wunsch

                  System wide configuration file is "/etc/avrdude.conf"
                  User configuration file is "/root/.avrduderc"
                  User configuration file does not exist or is not a regular file, skipping

                  Using Port                    : /dev/ttyAMA0
                  Using Programmer              : arduino
                  Overriding Baud Rate          : 38400
avrdude-original: stk500_recv(): programmer is not responding

avrdude-original done.  Thank you.


* Getty has been removed from ttyAMA0 in /etc/inittab

* The RFM12pi flashes when power is applied to the RPi, however a minicom session (minicom -b 38400 -D /dev/ttyAMA0) doesn't display a thing!

The unclear info on the wiki page for the RFM1pi, including references to forum discussions and info the git page doesn't make the setup easy for a new user.

If someone could give the step-by-step instruction how to get it working, it would be really appreciated.

Thanks in advance!

mharizanov's picture

Re: RFM12pi

Looks to me like it is not auto resetting for the firmware update. Check the second half of the introduction article here: http://harizanov.com/2013/02/new-rfm2pi-board-in-the-works/

Also you may find it easier to just use the prepared SD card image linked in the RFM2Pi WIKI, give it a try too.



DkYguy's picture

Re: RFM12pi

Thanks for you reply.

* The emonSD-13-08-14.img.zip image doesn't seem to include the software needed.

* The link on the wiki, "pre-built emoncms Raspberry Pi SD card image" is a dead link to https://github.com/emoncms/docs/blob/master/raspberrypiimage.md and I couldn't find the file anywhere else.

Once again, the wiki should really need a cleanup by someone that knows the things. :)

glyn.hudson's picture

Re: RFM12pi

pb66's picture

Re: RFM12pi

Getty has been removed from ttyAMA0 in /etc/inittab

​Did you also edit /boot/cmdline.txt and reboot for the changes to take effect?

If you happen to be using my "IDE friendly version"  I have just come to realize the imposed mandatory use of ttyS0 instead of  ttyAMA0 by the IDE was also true of the command line version since the modification. I have now edited the script to accept either reference.

You can either update avrdude-rpi via git or just change your command line above to use S0, ie

avrdude -v -c arduino -p ATMEGA328P -P /dev/ttyS0 -b 38400

If it is neither of these it will probably be an issue with the symlinks what does this return ?

ls -la /usr/bin/avrdude*

I get

lrwxrwxrwx 1 root root     26         Jan 25 15:51 /usr/bin/avrdude -> /usr/bin/avrdude-autoreset
-rwxr-xr-x 2   pi    pi        183       Jan 25 17:32 /usr/bin/avrdude-autoreset
-rwxr-xr-x 1   root root     275208 May 23  2012 /usr/bin/avrdude-original


Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.